
L a s t u p d a t e d i n J a n 2 0 1 1 P a g e 1

PC Requirements and Technical Help 
 
Q1. How do I clear the browser’s “cache”? 
 
A1. Clear your browser's cache, and close all other applications that are running in your PC 

to free up memory space. For instructions on clearing “cache” (temporary internet files), 

please follow the below steps according to your browser versions. 

For Internet Explorer 6.x browser 

1) Go to "Tools" menu 

2) Click on "Internet Options" 

3) Go to "General Tab" 

4) Click on "Delete Files..." under "Temporary Internet Files" 

5) Click "OK" on the "Delete Files" dialog box 

6) Click "OK" again to exit the Internet Options 

For Internet Explorer 7.x browser 

1) Go to "Tools" menu 

2) Click on "Internet Options" 

3) Go to "General Tab" 

4) Click "Delete" button under Browsing History section 

5) Click "Delete all…" button 

6) Click "Yes" button on the new pop-up window 

7) Click "OK" to exit the Internet Options dialog 

For Internet Explorer 8.0 and above browser 

1) Go to "Tools" menu 

2) Click on "Internet Options" 

3) Go to "General Tab" 

4) Click "Delete" button under Browsing History section 

5) Check all boxes next to the available options 

6) Click "Delete" button 

7) Click "OK" to exit the Internet Options dialog 

For Mozilla Firefox 3.0 and above in Windows OS 

1)   Go to "Tools" in menu bar 

2)   Click "Options…" 

3)   Go to "Privacy” Tab 

4)   Click “Clear your recent history” or "Clear all current history” 
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5)  In the new pop up window, choose “Time range to clear:” from dropdown list to 

“Everything” 

6)   Check all boxes of Details 

7)   Click "Clear Now" 

8)   Click “OK” to exit the Options dialog 

           For Apple Safari 5.0 and above in Macintosh OS 

1) Click "Safari" on the menu bar 

2) Click "Empty Cache…” 

3) Click "Empty" button on the dialog box 

For Mozilla Firefox 3.0 and above in Macintosh OS 

1)   Go to "Tools" in menu bar 

2)   Click "Clear Recent History…" 

3)  In the “Clear Recent History” window, choose “Time range to clear:” from dropdown 

list to “Everything” 

4)   Check all boxes of Details 

5)   Click "Clear Now" 

If your PC hangs, please switch off for 5 or 10 minutes and open another browser to 

access myTax Portal again. 

 

Q2.  What is the minimum hardware requirement for e-Filing? 

A2.  The minimum hardware requirement is: 

a) Pentium III PC and above with 256 RAM 

b) 56 kbps modem with connection to a local ISP 

 

Q3.  What is the minimum software requirement for e-Filing? 

A3.  For PC running Windows Operating system: 

a) Operating System : Windows 2000, Windows XP, Windows Vista or Windows 7 and 

above 

b) Browser: Internet Explorer 6.0 and above or Mozilla Firefox 3.0 and above 

 For Apple computer running Macintosh Operating system: 

Supported configurations are as follows: 

Mac OS X 10.5 with Safari Browser 5.0 and above or Mozilla FireFox 3.0 and above. 
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Q4.  How do I check the version of my operating system? 

A4.  For PC running Windows 2000 or Windows XP operating system: 

1) Click "Start" on your taskbar 

2) Select "Control Panel" 

3) Go to "System" 

4) Go to "General" tab in the System Properties dialog box 

5) The operating system version is displayed under "System:" 

            For PC running Windows Vista or Windows 7 operating system: 

1) Click "Start" on your taskbar 

2) Select "Control Panel" 

3) Go to "System and Maintenance" or “System and Security” 

4) Click “System” 

5) The operating system version is displayed under "Windows edition" 

For Apple computer running Macintosh operating system: 

1) Click the Apple picture on the top left menu bar 

2) Click "About This Mac" 

3) The operating system version is displayed under "Mac OS X" 

 

Q5.  How do I check the version of my browser? 

A5.  For PC running Windows operating system: 

1) Click “Help” on the menu bar 

2) For Internet Explorer, click “About Internet Explorer” 

3) For Mozilla Firefox, click “About Mozilla Firefox” 

For Apple computer running Macintosh operating system: 

1) For Safari, click “Safari” on the menu bar and then click “About Safari” 

2) For Mozilla Firefox, click “Firefox” on the menu bar and then click “About Mozilla 

Firefox” 

 

Q6.  If you have done the steps in question 1 but still experiencing page errors. 

A6.  You may email us at taxclear@iras.gov.sg with the following details:  

a) Date and time when you encountered problems; 

b) The operating system you are using (e.g. Windows XP, Macintosh OS X Tiger, etc. 

Please refer to Q4) 
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c) The browser type and version number (e.g. Internet Explorer 6, Apple Safari 5.0, etc. 

Please refer to Q5) 

d) The name of the Internet Service Provider (ISP) (e.g. Starhub, Singtel,etc) 

e) The error messages you encountered or the screenshot of the errors encountered (if 

available) 

Alternatively, you may call 1800 356 8300 for assistance.  

 

Q7.  How do I save the Consolidated Statement / Acknowledgement page? 

A7.  For PC running Windows with Internet Explorer browser 

1) Select "File -> Save As" on the top of the browser window menu 

2) Select the location to save the HTML document 

3) Type in the desired file name in "File name:" and click on "Save" button 

For PC running Windows with Firefox browser 

1) Select "File -> Save Page As" on the top of the browser window menu 

2) Select the location to save the HTML document 

3) Type in the desired file name in "File name:” 

4) Choose “Web Page, complete” in “Save as type:” dropdown list 

5) Click on "Save" button 

For Apple computer with Safari browser 

1) Select "File -> Save As…" on the top of the browser window menu 

2) Type in the desired filename in "Save As:" or “Export As:” 

3) Select the location to save the HTML document 

4) Select “Web Archive” under the “Format:” box 

5) Click on "Save" button 

For Apple computer with Mozilla Firefox browser 

1)   Select "File -> Save Page As…" on the top of the browser window menu 

2)   Type in the desired filename in "Save As:" 

3)   Select the location to save the HTML document 

4)   Select “Web Page, complete” under the “Save As:” box 

5)   Click on "Save" button 
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Q8.  What should I do if I see the following error messages upon login: 

(i) “We are unable to process your request. Please make sure that Java is enabled 

and applet is initialized” or 

(ii) “Your browser is not Java enabled. In order to proceed, please clickhere for 

further instructions.” 

A8.  Step 1: Please check whether you have Java installed. We recommend that your PCs 

are installed with JRE 1.5 or above. To check the JRE version installed in your computer 

please follow these steps: 

  For PC running Windows 2000 or Windows XP operating system: 

1) Open Windows “Control Panel” 

2) Double-click the “Java” icon to launch the Java Control Panel (if you are unable to 

find Java icon, please proceed to no.4 below) 

3) Under the “General” tab click on the “About” button, the next screen that appears will 

depend on the JRE version installed in the PC. Please check if your PCs are 

installed with JRE 1.5 or above 

For PC running Windows Vista or Windows 7 operating system: 

1)  Open Windows “Control Panel” 

2)   Click “Programs” 

3)  Double-click the “Java” icon to launch the Java Control Panel (if you are unable to 

find Java icon, please proceed to no.4 below) 

4)  Under the “General” tab click on the “About” button, the next screen that appears will 

depend on the JRE version installed in the PC. Please check if your PCs are 

installed with JRE 1.5 or above 

For Apple computer running Macintosh operating system: 

1) Launch terminal application 

2) Type Java –version 

3) Please check whether it shows Java version "1.5.0_...."  or above 

(If you are unable to see the Java version number, please proceed to no.4) 

4) To install or update to the latest Java version follow these steps 

- Go to http://www.java.com/en/download/index.jsp 

- Click the "Free Java Download" button 

- Follow the step by step instructions 
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Step 2: Please check if your browser setting is Java enabled. To do so, follow the steps 

below: 

Microsoft Internet Explorer 6.0, 7.0 or 8.0 and above for Windows 

1) Click the 'Tools' menu on your browser 

2) Select 'Internet Options' 

3) Click the 'Security' tab 

For the Internet zone, be sure that the Security level is set to 'Medium' or below. 

If you have chosen to customize your security settings for the Internet zone, be sure that 

the following is set: 

- Under the 'Java VM' heading’ or ‘Microsoft VM’, 'Java permissions' is not set to 

'Disable Java' 

- Under the Scripting heading, 'Scripting of Java Applets' is set to 'Enable' or 

'Prompt' 

- Click 'OK' to close the 'Security Settings' dialog 

4) Next, click the 'Advanced' tab 

- Scroll down till you see the sub heading 'Java VM' or 'Microsoft VM' 

- Please ensure that the 'Java JIT compiler enabled' checkbox is set 

5) Click 'OK' to close the 'Internet Options' dialog 

Mozilla Firefox 3.0 and above for Windows 

1) Click "Tools" on the menu bar 

2) Click "Options" 

3) Go to "Content" tab 

4) Make sure the "Enable Java" and "Enable Java script" are checked 

5) Click "OK" button to exit from this dialog 

Apple Safari  5.0 and above for Macintosh OS X 

1) Click "Safari" on the Safari menu bar 

2) Click "Preferences…" 

3) Go to "Security" tab 

4) Make sure the "Enable Java" and "Enable Java script" are checked under "Web 

Content" section 

5) Close the window 
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Mozilla Firefox 3.0 and above for Macintosh OS X 

1) Click "Firefox" on the Firefox menu bar 

2) Click "Preferences…" 

3) Go to "Security" tab 

4) Make sure the “Enable Java” (if this option is displayed under “Security” tab) and 

"Enable JavaScript" are checked 

5) Close the window 

 

Q9.  What is the requirement for executing Java and JavaScript? 

A9.  For your browser to execute Java and JavaScript, you must use a JavaScript capable 

browser, such as Internet Explorer (version 6.0 and above), Mozilla Firefox (version 3.0 

and above) or Apple Safari (version 5.0 and above). Please refer to the answer of 

question 8 to check java setting. 

 

Q10.  How do we enable our browser to accept cookies? 

A10.  For Internet Explorer Version 6.0, Version 7.0 and Version 8.0 and above on a Microsoft 

Windows computer: 

1) Click "Tools" on menu bar 

2) Click on the "Internet Options" tab 

3) Click on the "Privacy" tab 

4) Click on the "Advanced" button 

5) Click on "Override automatic cookie handling” 

6) For first-party and third-party cookies, click on "Accept" 

For Mozilla Firefox 3.0 and above on a Microsoft Windows computer: 

1)    Click "Tools" on menu bar 

2)    Click “Options...” 

            3)    Select "Privacy" icon on top 

4)    Set "Firefox will:" to "Remember history". 

5)    Click “OK” 

For Safari  5.0 and above on an Apple Macintosh computer: 

1) Click "Safari" on the Safari menu bar 

2) Click "Preferences…" 

3) Go to "Security" tab on top 
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4) Make sure the "Accept Cookies" is not set to "Never" 

5) Close the window 

 

For Mozilla Firefox 3.0 and above on an Apple Macintosh computer: 

1) Click "Firefox" on the Firefox menu bar 

2) Click "Preferences…" 

3) Select "Privacy" icon on top  

4) Set "Firefox will:" to "Remember history" 

5) Close the window 

 

Q11.  Besides ensuring that my PC satisfies the technical requirements, what other 

measures should I take before proceeding to e-File? 

A11. It is recommended that you close all other software applications during your e-Filing 

session. 

 

Q12.  When e-Filing, can I click the browser's back button to return to the previous 

page? 

A12.  We strongly advise you not to use your browser's <back> button while e-Filing. Please 

note that there are tabs on every screen that direct you to the respective e-Filing page. 

 

Q13.  What should I do if I click “Submit”, but do not see an Acknowledgment Page? 

A13.  If your e-Filing were successfully submitted, you will see an Acknowledgement Page on 

the screen after you click "Submit". However, in the event of the Acknowledgement page 

is not shown, please click on 'Last Completed Portal Transactions' under 'My Messages' 

at myTax Portal. You will see “eFiled IR21 on dd/mm/yyy hh:mm:ss” if the e-Filing was 

successful. Otherwise, please proceed to e-File again. 

 Alternatively, you can also check the e-Filing of Form IR21 was successful via IR21 

Status page. 

 

Q14. What should I do if the server is down or the page cannot be displayed? 

A14. We are sorry for the technical problems you have encountered. We wish to explain that 
our system is experiencing some technical problems at this juncture due to unforeseen 
technical errors. Hence, some taxpayers may experience various technical problems 
when they attempt to e-File. 
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Please try to e-File again a few hours later. If you still encounter technical problems, 
please try the following steps: 
1) Please switch off your PC and wait for about 10 to 20 minutes 
2) Open a new browser and log in to myTax Portal 
3) e-File the Form IR21 once more 
4) If you hit the same error message/experience any slowness in the system again, 

please re-perform Steps 1-3.  
 
If you still encounter an error, please email us at taxclear@iras.gov.sg with the following 
details:  
a) date and time when you encountered problems; 
b) the operating system you are using (e.g. Windows XP, Macintosh OS, etc); 
c)  the browser type and version number (e.g. Internet Explorer 6, Apple Safari 5.0,etc.); 
d) the name of the Internet Service Provider (ISP) (e.g. Starhub, Singtel, etc); 
e) the error messages you encountered or the screenshot of the errors encountered (if 

available); and 
f) your name and contact number. 
 
Alternatively, you may contact us at 1800 356 8300 for assistance. 
 
Please accept our apologies for the inconvenience caused. Thank you for your 
understanding. 

 

Q15.  How do I install Adobe reader? 

A15.  Some of our guides may require you to have an Adobe Reader in order to display the 

contents. If you do not have an Adobe Reader please go to 

http://get.adobe.com/reader/otherversions/ to download the latest version suitable for 

your computer. 

 

Q16.  Why am I unable to view documents using View Correspondence/ Notices? 

A16.  Please follow the below steps according to your browser versions 
Microsoft Internet Explorer 6.0, 7.0 or 8.0 and above for Windows 

1) Click "Tools" on menu bar 

2) Click on the "Internet Options” 

3) Click on the "Security" tab 

- Click on the "Custom Level…" button 

- Scroll down until you see a title called "Downloads" 

- Set the “Automatic prompting for file downloads” to “Enable” 

- Scroll down until you see a title called " Miscellaneous" 

- Set the “Use Pop-up Blocker” to “Disable” 
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- Click "OK" button 

4) Click on the “Privacy” tab 

- Make sure that the “Block pop-ups” is unchecked 

5) Click on the "Advanced" tab 

- Scroll down until you see a title called "Security" 

- Make sure that the “Do Not save encrypted pages to disk" is unchecked 

- Click "OK" button 

6) Restart the web browser 

Mozilla Firefox 3.0 and above for Windows 

1)  Click "Tools" on the menu bar 

2)  Click "Options" 

3)  Go to "Content" tab 

4)  Make sure the "Block pop-up windows” are unchecked 

5)  Click "OK" button to exit from this dialog 

Safari  5.0 and above for Apple Macintosh 

            1)  Click "Safari" on the Safari menu bar 

2)  Click "Preferences…" 

3)  Go to “Security” tab 

            4)  Make sure “Block pop-up windows” is unchecked 

            5)  Close the window 

Mozilla Firefox 3.0 and above for Apple Macintosh 

            1)  Click "Firefox" on the Firefox menu bar 

2)  Click "Preferences…" 

3)  Go to “Content” tab 

            4)  Make sure “Block pop-up windows” is unchecked 

            5)  Close the window 


