Contents

Q1. What are the browser compatibility requirements for accessing myTax Portal? .................................................. 3
Q2. I’ve encountered the “System has encountered some technical problems. You can close your browser and try again later. Alternatively, you can try on another browser using your computer or mobile device.” error message upon login. What should I do? ................................................................. 4
Q3. How do I check the version of my browser? ........................................................................................................ 4
Q4. How do I check the version of my operating system? .............................................................................................. 8
Q5. How do I save the Income, Deductions and Reliefs Statement/ Consolidated Statement/ Acknowledgement page? .......................................................................................................................... 13
Q6. How do I clear the browser’s cache (temporary internet files)? ........................................................................... 16
Q7. I am facing technical difficulties or page errors when accessing myTax Portal on Google Chrome/Firefox. What should I do? ......................................................................................................................... 20
Q8. How do I enable cookies on my browser? .............................................................................................................. 21
Q9. Can I click the browser’s back button to go back to the previous page when accessing myTax Portal? ........................................................................................................................................ 26
Q10. What should I do if I hit “The page cannot be displayed” error? ...................................................................... 27
Q11. How do I install Adobe Reader? .......................................................................................................................... 28
Q12. Can I access myTax Portal using the same login credentials on multiple browsers/devices? ..... 28
Q13. What should I do if I am still experiencing page errors after completing all the necessary steps? .................................................................................................................................................. 28

Contact Information

.................................................................................................................................................................................. 29
Q1. What are the browser compatibility requirements for accessing myTax Portal?

A1. **For PCs/desktops:**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Browser Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7.0</td>
<td>Internet Explorer 11</td>
</tr>
<tr>
<td></td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td>Windows 8.1</td>
<td>Internet Explorer 11</td>
</tr>
<tr>
<td></td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td>Windows 10</td>
<td>Internet Explorer 11</td>
</tr>
<tr>
<td></td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td>Macintosh Operating System 10.15</td>
<td>Firefox 71</td>
</tr>
<tr>
<td>Catalina</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 13.0</td>
</tr>
<tr>
<td>Macintosh Operating System 10.14</td>
<td>Firefox 71</td>
</tr>
<tr>
<td>Mojave</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 12.1</td>
</tr>
<tr>
<td></td>
<td>Safari 13.0</td>
</tr>
<tr>
<td>Macintosh Operating System 10.13</td>
<td>Firefox 71</td>
</tr>
<tr>
<td>High Sierra</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 12.1</td>
</tr>
<tr>
<td></td>
<td>Safari 13.0</td>
</tr>
<tr>
<td>Macintosh Operating System 10.12</td>
<td>Firefox 71</td>
</tr>
<tr>
<td>Sierra</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 12.1</td>
</tr>
</tbody>
</table>

**For iPhones:**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Browser Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>iOS 13</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 13.0</td>
</tr>
<tr>
<td>iOS 12</td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Safari 12.0</td>
</tr>
</tbody>
</table>

**For Android Phones:**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Browser Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Android 9 - Pie</td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Samsung Internet 10.2</td>
</tr>
<tr>
<td>Android 8 - Oreo</td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
</tbody>
</table>
Q2. I’ve encountered the “System has encountered some technical problems. You can close your browser and try again later. Alternatively, you can try on another browser using your computer or mobile device.” error message upon login. What should I do?

A2. Please close all existing browsers and log in again on a new window/session. Alternatively, you can try on another browser using your computer or mobile device.

Q3. How do I check the version of my browser?

A3. For PCs running Windows:

a) **Internet Explorer**: Click the gear icon at the top-right corner and select “About Internet Explorer”.

<table>
<thead>
<tr>
<th>Technical FAQ</th>
<th>Samsung Internet 10.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Android 7 - Nougat</td>
<td>Firefox 71</td>
</tr>
<tr>
<td></td>
<td>Google Chrome 79</td>
</tr>
<tr>
<td></td>
<td>Samsung Internet 10.2</td>
</tr>
</tbody>
</table>
b) **Firefox:** Click the menu icon at the top-right corner, click the question mark icon at the bottom of the menu, then select “About Firefox”. You may also click “Help” in the menu bar and select “About Firefox”.
c) **Google Chrome:** Click the menu icon at the top-right corner. In older versions, select “About Google Chrome” in the menu. In newer versions, select “Help and about”, then select “About Google Chrome”.

![Google Chrome](image)

d) **Microsoft Edge:** Click the menu icon at the top-right corner and select “Settings”. Scroll to the bottom of the menu and look for the “About this app” header.

![Microsoft Edge](image)
For Apple computers running Macintosh:

a) **Safari**: Click “Safari” on the menu bar and select “About Safari”.

b) **Firefox**: Click “Firefox” on the menu bar and select “About Mozilla Firefox”.

c) **Google Chrome**: Click the menu icon at the top-right corner. In older versions, select “About Google Chrome” in the menu. In newer versions, select “Help and about”, then select “About Google Chrome”.

For Smartphones/ Tablets:

a) **Safari**: The version of the *iPhone/ iPad’s operating system* will be the version number of the browser.

b) **Google Chrome**: Click on the menu icon at the top-right corner and select “Settings”, then select “Google Chrome”.
c) **Firefox**: Click on the menu icon at the top-right corner and select “Settings”.

Q4. How do I check the version of my operating system?

A4. **For PCs running Windows:**

   a) **Windows 7**: Right-click on “My Computer” in the Windows Desktop or in “Start” menu, and select “Properties”
b) **Windows 8 and above**: Type ‘about’ in the search box on your taskbar, and select “About your PC”.

**For Apple computers running Macintosh:**
Click the Apple icon on the top-left menu bar and select "About This Mac".

**For Smartphones/ Tablets:**

a) **iPhones/iPad**: Click “Settings”, select “General”, and then select “About”.

b) **Android**: Click “Settings” and select “About Phone”.
c) **Samsung tablet**: Tap “Settings”, scroll to and tap “About Tablet”, select “Software Information.”
Technical FAQ

Settings
- Wallpaper
- Advanced features
- Device maintenance
- Apps
- Lock screen and security
- Cloud and accounts
- Google
- Accessibility
- General management
- Software update
- User manual

About Tablet
- Status
- Legal information
- Device name: Galaxy Tab S2
- Model number: SM-T813

Software information
View the currently installed, Android version, baseband version, kernel version, build number, and more.

Battery information
View your device's battery status, remaining power, and other information.

Looking for something else?
Reset
Q5. How do I save the Income, Deductions and Reliefs Statement/ Consolidated Statement/ Acknowledgement page?

A5. For PCs running Windows:

a) **Internet Explorer:**
   1) Select "File > Save As" from the top of the browser window menu
   2) Select the location to save the HTML document
   3) Type in the desired file name in "File name:" and click on "Save" button

b) **Firefox:**
   1) Select "File > Save Page As" from the top of the browser window menu
2) Select the location to save the HTML document
3) Type in the desired file name in "File name:"
4) Choose “Web Page, complete” in “Save as type:" dropdown list
5) Click on "Save" button

c) Google Chrome:
1) Click on the main menu button located in the top right corner of your browser window.
2) Under “More tools” sub-menu, click on “Save Page As” to open a standard save file dialog that overlays your browser window. Note: Appearance varies depending on your operating system.
3) Select the location to save the HTML document, followed by the appropriate step(s) to complete the process.

d) Microsoft Edge:
1) Click on the gear icon at the top right corner of the browser window.
2) Select “File > Save As”.
3) Select the location to save the HTML document, followed by the appropriate step(s) to complete the process.

For Apple computers running Macintosh:

a) Safari:
1) Select "File > Save As..." from the top of the browser window menu
2) Type in the desired filename in "Save As:" or “Export As:’”
3) Select the location to save the HTML document
4) Select “Web Archive” under the “Format:" box
5) Click on "Save" button

b) Firefox:
1) Select "File > Save Page As..." from the top of the browser window menu
2) Type in the desired filename in "Save As:"
3) Select the location to save the HTML document
4) Select “Web Page, complete” under the “Save As:” box
5) Click on "Save"

c) **Google Chrome:**
   1) Click on the main menu button located in the top right corner of your browser window.
   2) Under “More tools” sub-menu, click on “Save Page As” to open a standard save file dialog that overlays your browser window. Note: Appearance varies depending on your operating system.
   3) Select the location to save the HTML document, followed by the appropriate step(s) to complete the process.
Q6. How do I clear the browser’s cache (temporary internet files)?

A6. Close all other applications running in your PC to free up memory space. Press Ctrl + Shift + Delete (Windows)/ Shift + ⌘ Command + Delete (Mac OS), and follow the instructions below:

a) **Internet Explorer:**
   1) Check the box next to “Temporary Internet files”
   2) Click “Delete”
   3) Click “OK” to exit the Internet Options dialog

![Screenshot of Internet Explorer cache settings]

b) **Firefox:**
   1) In the “Clear All History” window that appears, set the “Time range to clear”: to “Everything”.
   2) Expand the “Details” and ensure “Cache” is checked.
   3) Click “Clear Now”.

![Screenshot of Firefox cache settings]
c) **Google Chrome**:  
1) Select the period of time you wish to delete cached information using the “Clear the following items from” menu.  
2) Check “Cached images and files”.  
3) Click “Clear browsing data”.

![Google Chrome Clear Browsing Data](image)

d) **Safari**:  
1) Click ”Safari” on the menu bar and select “Preferences”.  
2) Click “Advanced” tab and check “Show Develop menu in bar” option to add the menu to Safari by default.  
3) Click “Develop” on the menu bar and select “Empty Caches”.  

![Safari Develop Menu](image)
e) **Microsoft Edge:**
1) Click the menu at the top-right corner and select “Settings”.
2) Under “Clear browsing data”, click “Choose what to clear”.
3) Check “Cached data and files” and click “Clear”.
If your PC hangs, please switch it off for 5 or 10 minutes, restart, and try to access myTax Portal again.

Q7. I am facing technical difficulties or page errors when accessing myTax Portal on Google Chrome/Firefox. What should I do?

A7. You may have ticked the box to prevent the page from creating additional dialogues. Please close your browser and reopen it. Ensure that the box is unchecked.

a) **Google Chrome:**

b) **Firefox:**
Q8. How do I enable cookies on my browser?

A8. For PCs running Windows:

   a) Internet Explorer:
      1) Click the gear icon at the top-right corner of the menu bar.
      2) Click "Internet Options" and select “Privacy”, then select “Advanced”.
      3) On the next window, select “Accept” for first-party and third-party cookies.
      4) Click "OK"

   b) Firefox:
      1) Click the menu icon at the top-right corner and select the “Options” tab.
      2) Click "Privacy" and select the “Firefox will ‘Remember History’” option. A window will pop up prompting you to restart Firefox in order to apply the changes.
      3) Click “OK”.

   ![Internet Explorer settings](image1.png)
   ![Advanced Privacy Settings](image2.png)
a) **Google Chrome:**

1) Click the menu icon at the top-right corner and select “Settings”.
2) Click on “Show Advanced Settings” link.
3) Go to “Privacy” section and select “Content settings”.
4) Select “Allow local data to be set” option.
b) **Microsoft Edge:**

1) Click the menu icon at the top-right corner and select “Settings”.
2) Click on “View Advanced Settings”.
3) Under “Cookies”, select “Don’t block cookies”.

For Apple computers running Macintosh:
a) **Safari:**
1) Click "Safari" on the Safari menu bar
2) Click "Preferences…"
3) Go to “Privacy” tab on top
4) Make sure the "Block Cookies" is set to "Never"
5) Close the window

b) **Firefox:**
1) Click "Firefox" on the Firefox menu bar
2) Click "Preferences…"
3) Select "Privacy" icon on top
4) Set "Firefox will..." to “use custom settings for history"
5) Select the "Accept cookies from sites" checkbox.
6) Click “OK”.
c) **Google Chrome:**

1) Click “Chrome” on the Google Chrome menu bar.
2) Click “Preferences” and select “Show Advanced Settings”.
3) Under “Privacy”, click “Content Settings”.
4) Under “Cookies”, check “Allow local data to be set”
   - Ensure that “Block all third-party cookies without exception” and “Clear cookies and other site data when I quit my browser” are unchecked.
5) Click “Done” and close the “Settings” page.
Q9. Can I click the browser's back button to go back to the previous page when accessing myTax Portal?

A9. Do not use the back button on your browser when accessing myTax Portal. You should use the navigation menu to navigate through the portal, or where applicable, there are “Back to” hyperlinks to return to the previous screen(s).
Q10. What should I do if I hit “The page cannot be displayed” error?

A10. Please ensure that “Use TLS 1.1” is checked by following these steps:
1) Go to your Internet Properties
2) Click on the “Advanced” tab
3) Look for “Use TLS 1.1” in the list
4) Please check the box for “Use TLS 1.1”

After completing the above steps, please switch off your computer for 5 or 10 minutes, restart, and try to access myTax Portal again.
If problem persists, you may Livechat us from 8.00am to 5.00pm (Mon to Fri) or email tpsmu@iras.gov.sg with the following details:

1) Date and time when you encountered problems;
2) **Browser type and version number** (e.g. Google Chrome 70, Microsoft Edge 42, Apple Safari 11 etc.)
3) **Operating system** you are using (e.g. Windows 10, Macintosh OS 10.13 High Sierra, iOS11, Android 8 etc.)
4) Whether problem encountered while using desktop or mobile eService
5) Description of steps leading to problem faced
6) Error messages or the screenshot of the errors encountered (if any)

**Q11. How do I install Adobe Reader?**

A11. Some of our guides may require you to have an Adobe Reader to display the contents. If you do not have an Adobe Reader, please go to http://get.adobe.com/reader/otherversions/ to download the latest version suitable for your computer.

**Q12. Can I access myTax Portal using the same login credentials on multiple browsers/devices?**

A12. No, myTax Portal does not support concurrent sessions on multiple browsers/devices for the same login credentials. For security reasons, you will be logged out from all previous sessions.

**Q13. What should I do if I am still experiencing page errors after completing all the necessary steps?**

A13. If problem persists, you may Livechat us from 8.00am to 5.00pm (Mon to Fri) or email tpsmu@iras.gov.sg with the following details:

1) Date and time when you encountered problems;
2) **Browser type and version number** (e.g. Google Chrome 70, Microsoft Edge 42, Apple Safari 11 etc.)
3) **Operating system** you are using (e.g. Windows 10, Macintosh OS 10.13 High Sierra, iOS11, Android 8 etc.)
4) Whether problem encountered while using desktop or mobile eService
5) Description of steps leading to problem faced
6) Error messages or the screenshot of the errors encountered (if any)
Contact Information

For technical enquiries on myTax Portal, please Livechat us from 8.00am to 5.00pm (Mon to Fri) or email tpsmu@iras.gov.sg.

Published by
Inland Revenue Authority of Singapore

Published on 29 May 2020

The information provided is intended for better general understanding and is not intended to comprehensively address all possible issues that may arise. The contents are correct as at 23082017 and are provided on an “as is” basis without warranties of any kind. IRAS shall not be liable for any damages, expenses, costs or loss of any kind however caused as a result of, or in connection with your use of this FAQ.

While every effort has been made to ensure that the above information is consistent with existing policies and practice, should there be any changes, IRAS reserves the right to vary its position accordingly.

© Inland Revenue Authority of Singapore